徹底解決android API 不兼容問題 – Android移動開發技術文章_手機開發 Android移動開發教學課程

 

比如高版本API廢棄瞭低版本的API,這樣的話,還是用低版本的API開發的話,再低版本下運行,就會照成程序的崩潰,解決方案如下

 

大致結構:

假設SDK版本開始變化的SDK版本是sdkversion

 

if(sdk< sdkversion){

//加載低版本的實現activity的代碼

}else{

//加載高版本實現activity的代碼

}

 

www.aiwalls.com

 

上面兩個部分打開不同的activity 就可以瞭,不可以在一個activity寫兩個版本的代碼,那樣,在加載到內存的時候,會判斷沒相關API就會報錯!

 

知道這個問題困擾過大傢!總結的希望對大傢有幫助!

  作者 美一天

發佈留言