[android開發筆記]Unable to resolve target 'android-5' – Android移動開發技術文章_手機開發 Android移動開發教學課程

安裝Ecplise+ATD+Android SDK 開發android 時,最先想到的要運行寫例子,有個直觀的認識–什麼是Android。在Ecplise工作空間導入書上Android會出現錯誤,大部分是SDK 版本不符,如下錯誤提示:
Error:Unable to resolve target android-5


解決辦法:修改工程目錄下的default.properties文件裡的內容target=android-5改成target=android-7(或者其他版本)就可以瞭,最好用txt打開,然後修改之後保存,運行就可以瞭。
附:
使用高版本的SDK後再導入以前用低版本的project時,會遇到一些兼容性的問題。
    (1)Unable to resolve target android-5
   因為本機中現在使用的是2.1的SDK,API的版本是7;而導入的工程使用的是2.0開發的,其API版本是5。
   需要將default.properties中的target=android-5改為target=android-7就好瞭。
   但要註意,也要同步將AndroidManifest.xml中的<uses-sdk android:minSdkVersion=”5″ />改為<uses-sdk android:minSdkVersion=”7″ />,否則編譯中會警告提示使用的版本過低。
   (2)以上完成後,編譯中又出現一個新的錯誤:Conversion to Dalvik format failed with error 1
   這個與加載的SDK有關,通過“右鍵選擇工程build path -> configure build path… -> library發現導入的JARs中除瞭一個Android 2.1-update1外還有一個同路徑下的文件夾item,將其移除,clean一下再編譯就沒問題瞭。

發佈留言