Android導入源代碼出現Remove @Override問題解決方法

這個一般是因為配置文件中的JDK版本不對導致的   配置文件就是 工程目錄下.settings文件夾中org.eclipse.jdt.core.prefs文件
我們如果用UEdit或記事本打開他可以看到裡面的代碼是這樣的
01
#Wed Mar 21 16:05:12 CST 2012
02
eclipse.preferences.version=1 www.2tu.cc
03
org.eclipse.jdt.core.compiler.codegen.inlineJsrBytecode=enabled
04
org.eclipse.jdt.core.compiler.codegen.targetPlatform=1.5
05
org.eclipse.jdt.core.compiler.codegen.unusedLocal=preserve
06
org.eclipse.jdt.core.compiler.compliance=1.5
07
org.eclipse.jdt.core.compiler.debug.lineNumber=generate
08
org.eclipse.jdt.core.compiler.debug.localVariable=generate
09
org.eclipse.jdt.core.compiler.debug.sourceFile=generate
10
org.eclipse.jdt.core.compiler.problem.assertIdentifier=error
11
org.eclipse.jdt.core.compiler.problem.enumIdentifier=error
12
org.eclipse.jdt.core.compiler.source=1.5
可以看到這裡的配置是JDK1.5 

我們如果手動將這裡的1.5都修改成1.6  然後Refresh下項目就可以瞭.

如果還是有問題,那麼打開eclipse,window菜單下面的Preference,進入java,complier選項,把jdk改成1.6就行瞭。刷新一下項目。

作者:拉風的道長

發佈留言