Eclipse開發Android報錯Jar mismatch! Fix your dependencies

Eclipse開發Android報錯Jar mismatch! Fix your dependencies。當項目中引用瞭其他項目作為Library的時候,如果這幾個項目中都使用瞭android-support-v4.jar這個包時,很可能出現這個問題,出現這個問題的原因下圖中Error信息第一行說的很清楚,發現兩個版本不同的android-support-v4.jar在使用。

 

 

解決辦法:隻需要保證讓所有包含android-support-v4.jar的項目使用同版本的jar包即可。

1. 把原有的android-support-v4.jar全部移除。

2. 分別添加新jar包,然後clean一下所有相關的項目即可解決,添加方法如下圖。

You May Also Like