往android – Eclipse中導入新項目時,出現Remove @Override annotation錯誤提示

原因:編譯器版本的問題。Java 1.5的編譯器默認對父類的方法進行覆蓋,采用@Override進行說明;但1.6已經擴展到對接口的方法;所以如果還是以Java 1.5的編譯器來編譯的話,會出現錯誤。

解決辦案:
方案一、

在Eclipse中,compiler 都得設置到1.6。這包括Eclipse –> preference
–> compiler 下要改成1.6.這主要是針對同時裝瞭1.5, 1.6,而default is 1.5這種情況的。

方案二、

在Eclipse中按照提示直接刪除override。

發佈留言