如何在android4.0中開啟GPS

問題描述:

我的應用中要開啟GPS,一直到android2.3.6版本都運行正常。但是到瞭android4.0版本以後,就不行瞭。

不知道為什麼?在高版本裡應該怎麼設置呢?

解決方案:

試試下面的代碼:

[java]
public void turnGPSOn() 

     Intent intent = new Intent("android.location.GPS_ENABLED_CHANGE"); 
     intent.putExtra("enabled", true); 
     this.ctx.sendBroadcast(intent); 
 
    String provider = Settings.Secure.getString(ctx.getContentResolver(), Settings.Secure.LOCATION_PROVIDERS_ALLOWED); 
    if(!provider.contains("gps")){ //if gps is disabled  
        final Intent poke = new Intent(); 
        poke.setClassName("com.android.settings", "com.android.settings.widget.SettingsAppWidgetProvider");  
        poke.addCategory(Intent.CATEGORY_ALTERNATIVE); 
        poke.setData(Uri.parse("3"));  
        this.ctx.sendBroadcast(poke); 
    } 

public void turnGPSOn()
{
     Intent intent = new Intent("android.location.GPS_ENABLED_CHANGE");
     intent.putExtra("enabled", true);
     this.ctx.sendBroadcast(intent);

    String provider = Settings.Secure.getString(ctx.getContentResolver(), Settings.Secure.LOCATION_PROVIDERS_ALLOWED);
    if(!provider.contains("gps")){ //if gps is disabled
        final Intent poke = new Intent();
        poke.setClassName("com.android.settings", "com.android.settings.widget.SettingsAppWidgetProvider");
        poke.addCategory(Intent.CATEGORY_ALTERNATIVE);
        poke.setData(Uri.parse("3"));
        this.ctx.sendBroadcast(poke);
    }
}

 

發佈留言

發佈留言必須填寫的電子郵件地址不會公開。 必填欄位標示為 *